Print Page | Close Window

OnMarkerClick Event Not Firing in IOS

Printed From: TMS Software
Category: FMX Components
Forum Name: FMX WebGMaps / WebOSMaps
Forum Discription:
URL: http://www.tmssoftware.com/site/forum/forum_posts.asp?TID=4654
Printed Date: 23 Jan 2020 at 5:24pm


Topic: OnMarkerClick Event Not Firing in IOS
Posted By: Macias Jan Webber
Subject: OnMarkerClick Event Not Firing in IOS
Date Posted: 16 Dec 2014 at 7:05am
Hi...

For some reason the OnMarkerClick event is not firing in IOs. The target SDK is 8.1 that I used to compile my project is 8.1.

I tested the demo provided and it also not working when I click on a marker.

I am using Delphi XE7.....



Replies:
Posted By: Hoogeboom Gert
Date Posted: 04 Jan 2015 at 3:31pm
I have the same problem, any idee when it is going to work ?

Gert


Posted By: Macias Jan Webber
Date Posted: 05 Jan 2015 at 10:29pm
The response I got is they are still finding a solution to the problem.
It means we don't expect any solution anytime soon.

I wish they give us a free license on the other mapping component that actually works with IOS 8......


Posted By: Pieter Scheldeman
Date Posted: 06 Jan 2015 at 4:00am
Hi, 

We have retested this here in iOS 8.1 without changing code and are no longer able to reproduce this.
Can you retest this on your device? It might be possible that Google has changed something underlying.

Kind Regards, 
Pieter


Posted By: Hoogeboom Gert
Date Posted: 06 Jan 2015 at 12:09pm
I have IOS 8.1 but it stil isn't working here. I can drag the marker and it is clickable but no event is firing.

Gert


Posted By: Pieter Scheldeman
Date Posted: 07 Jan 2015 at 2:36am
We were linking against iOS 7 and deploying on iOS 8 therefore we could not reproduce it. We have retested this here while linking against iOS 8 and are able to reproduce it. Unfortunately this is a security issue in iOS that has changed between iOS 7 and iOS 8 and we are currently investigating a solution. Our apologies for the misunderstanding.

Kind Regards, 
Pieter


Posted By: Pieter Scheldeman
Date Posted: 07 Jan 2015 at 3:55am
Hi, 

We have implemented a fix that has been tested on iOS 8 and is backwards compatible with iOS 7. Could you retest the latest version (1.9.1.2) that has been uploaded?

Kind Regards, 
Pieter


Posted By: Macias Jan Webber
Date Posted: 08 Jan 2015 at 3:02am
Where can I upload the latest version? I am getting from the download link is only version 1.9.1.1....


Posted By: Nancy Lescouhier
Date Posted: 08 Jan 2015 at 4:05am
Can you try again? The issue with the download link should be fixed. Our apologies for this inconvenience.


Posted By: Hoogeboom Gert
Date Posted: 13 Jan 2015 at 12:43pm
It is working again

Gert



Print Page | Close Window