Print Page | Close Window

MapPanTo does not working

Printed From: TMS Software
Category: FMX Components
Forum Name: FMX WebGMaps / WebOSMaps
Forum Discription:
URL: http://www.tmssoftware.com/site/forum/forum_posts.asp?TID=13160
Printed Date: 17 Oct 2019 at 6:17pm


Topic: MapPanTo does not working
Posted By: Parra Alejandro Romero
Subject: MapPanTo does not working
Date Posted: 19 Mar 2019 at 7:25am
Hello

I see your MapPanTo does not work at first time why?

I recorded a video to show you this issue

When I first enter the map (it does not matter if it's Google Maps or Open Street Maps) it does not respect the MapPanTo with the longitude and latitude.

After I enter the second time it centers the point I already defined previously.

Why????

http://timbralofacil.com/descargas/tmschafa.html - https://timbralofacil.com/descargas/tmschafa.html




Replies:
Posted By: Bart Holvoet
Date Posted: 19 Mar 2019 at 9:15am
Hi,

Can you please make sure to call MapPanTo after the OnDownloadFinish has been triggered?

Alternatively you can use the MapOptions.DefaultLatitude and MapOptions.DefaultLongitude properties to initialize the map at a specific location.


Posted By: Parra Alejandro Romero
Date Posted: 19 Mar 2019 at 9:27am
Originally posted by Bart Holvoet

Hi,
Alternatively you can use the MapOptions.DefaultLatitude and MapOptions.DefaultLongitude properties to initialize the map at a specific location.

Bart

Default latitude and longitude inside MapOptions are not working too

I will test it with the DownloadFinish event and let you know


Posted By: Lee Parvin
Date Posted: 19 Mar 2019 at 9:57am
Yes, Ive also had the same problem......


Posted By: Bart Holvoet
Date Posted: 19 Mar 2019 at 10:02am
Can you please provide the following information so I can further investigate this?

Which version of Delphi are you using?
Which version of iOS or Android are you using?
If you are using a simulator, please try running the app on an actual device instead.
Does the same issue occur when you run your app on Windows?
Does the same issue occur with a new application that only contains a TMSFMXWebOSMaps component?



Posted By: Parra Alejandro Romero
Date Posted: 19 Mar 2019 at 10:05am
Originally posted by Bart Holvoet

Can you please provide the following information so I can further investigate this?

Which version of Delphi are you using?
Which version of iOS or Android are you using?
If you are using a simulator, please try running the app on an actual device instead.
Does the same issue occur when you run your app on Windows?
Does the same issue occur with a new application that only contains a TMSFMXWebOSMaps component?


Delphi XE 10.3.1
iOS 12.1.4


Posted By: Parra Alejandro Romero
Date Posted: 19 Mar 2019 at 10:13am
Originally posted by Bart Holvoet

Hi,

Can you please make sure to call MapPanTo after the OnDownloadFinish has been triggered?


It works with your recomendation above, thanks.



Print Page | Close Window