Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Import PostgreSQL DB

 Post Reply Post Reply
Author
Heuvel Patrick W View Drop Down
New Member
New Member
Avatar

Joined: 06 Oct 2017
Posts: 2
Post Options Post Options   Quote Heuvel Patrick W Quote  Post ReplyReply Direct Link To This Post Topic: Import PostgreSQL DB
    Posted: 25 Oct 2017 at 6:12am
Gday,

Trying to import a PostgreSQL database into Data Modeler, I get an error "cannot find datatype oid". Is there anything I can do to fix this short of re-creating the database?
Back to Top
Wagner R. Landgraf View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2367
Post Options Post Options   Quote Wagner R. Landgraf Quote  Post ReplyReply Direct Link To This Post Posted: 26 Oct 2017 at 12:41pm
Hello, could you provide more detailed info? Do you have the script of the table that is causing that issue? 
Back to Top
Heuvel Pat View Drop Down
New Member
New Member
Avatar

Joined: 17 Nov 2012
Posts: 5
Post Options Post Options   Quote Heuvel Pat Quote  Post ReplyReply Direct Link To This Post Posted: 26 Oct 2017 at 1:29pm


This is the message I get. I used an earlier database (8.4) for this one. I got the original message at work on a 9.4 database. No table name is given. This is a development database that has been around for about ten years! The work database is on a 9.4 server.

Again, this is from File|New|Import from Database in Data Modeler 3.0.0.0.

I'll create a basic database and send you the DML if I can get it to reproduce the problem.
Back to Top
Heuvel Pat View Drop Down
New Member
New Member
Avatar

Joined: 17 Nov 2012
Posts: 5
Post Options Post Options   Quote Heuvel Pat Quote  Post ReplyReply Direct Link To This Post Posted: 26 Oct 2017 at 1:34pm
Sorry, couldn't post the screenshot of the message! The message text is: "Cannot find datatype: oid".
No other detals are given.
Back to Top
Wagner R. Landgraf View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2367
Post Options Post Options   Quote Wagner R. Landgraf Quote  Post ReplyReply Direct Link To This Post Posted: 26 Oct 2017 at 1:41pm
Thank you, please send the info through support e-mail when you have it, thanks again.
Back to Top
Heuvel Patrick W View Drop Down
New Member
New Member
Avatar

Joined: 06 Oct 2017
Posts: 2
Post Options Post Options   Quote Heuvel Patrick W Quote  Post ReplyReply Direct Link To This Post Posted: 01 Nov 2017 at 2:37am
I created a simple database with two tables, where one table referenced the other through a foreign key. This was imported correctly. I then added a field to one table with the datatype oid, and this failed with the message I described earlier.
I couldn't find where I had used oid in my "live" database, looking at the source DML nor looking through the database objects, but it must be there somewhere!
Anyway, I hope this helps.
Back to Top
Wagner R. Landgraf View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2367
Post Options Post Options   Quote Wagner R. Landgraf Quote  Post ReplyReply Direct Link To This Post Posted: 01 Nov 2017 at 1:12pm
Version 3.0.1 has been released with a fix for that issue.
Back to Top
Heuvel Pat View Drop Down
New Member
New Member
Avatar

Joined: 17 Nov 2012
Posts: 5
Post Options Post Options   Quote Heuvel Pat Quote  Post ReplyReply Direct Link To This Post Posted: 01 Nov 2017 at 2:00pm
Thank you very much!
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down