Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Cannot compile Android project in debug mode anymo

 Post Reply Post Reply
Author
WIERZBICKI Stephane View Drop Down
Member
Member
Avatar

Joined: 29 Jan 2016
Posts: 80
Post Options Post Options   Quote WIERZBICKI Stephane Quote  Post ReplyReply Direct Link To This Post Topic: Cannot compile Android project in debug mode anymo
    Posted: 14 Mar 2017 at 3:07pm
Hello,

I'm getting this error when compiling my project in debug mode (Android / Delphi Berlin Update 2)

[DCC Error] TMSLoggingUtils.pas(152): E2003 Identifier not declared : 'DWORD'
[DCC Error] TMSLoggingUtils.pas(154): E2005 'DWORD' is not an identifier type
[DCC Error] TMSLoggingUtils.pas(223): E2005 'DWORD' is not an identifier type
[DCC Error] TMSLoggingUtils.pas(228): E2005 'DWORD' is not an identifier type
[DCC Fatal error] Datamodule.Main.pas(29): F2063 Cannot compile used unit 'TMSLoggingUtils.pas'

Everything is fine when compiling in release mode.
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3193
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 14 Mar 2017 at 3:13pm
Hi, 

We have tested this here in RAD Studio Berlin Update 2 but are not able to reproduce this issue. The TMSLoggingUtils unit is compiling succesfully here. Are you using the latest version? Can you perform a clean and rebuild operation on your project?
Back to Top
WIERZBICKI Stephane View Drop Down
Member
Member
Avatar

Joined: 29 Jan 2016
Posts: 80
Post Options Post Options   Quote WIERZBICKI Stephane Quote  Post ReplyReply Direct Link To This Post Posted: 14 Mar 2017 at 7:15pm
Hi,

I've already did it.
I'm using latest version. I'm getting this since version 1.2.0.2.


Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3193
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 17 Mar 2017 at 2:59pm
Hi, 

We have recently updated TMSLogging to 1.2.0.3. We are not able to reproduce this issue with the Dword identifier so it's still unclear why this problem manifests. Are you compiling with default compiler settings?
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down