Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Cloud FMX vs VCL

 Post Reply Post Reply
Author
Traversi Angel View Drop Down
Member
Member
Avatar

Joined: 16 Jul 2014
Posts: 40
Post Options Post Options   Quote Traversi Angel Quote  Post ReplyReply Direct Link To This Post Topic: Cloud FMX vs VCL
    Posted: 22 Jun 2015 at 2:55pm
Hello

Sorry, my english is bad.

For several months I have a Windows application that connects to Twitter with the Cloud VCL (2.9.1.0) components compiled with XE6 and works OK.
Now I want to do the same with Cloud FMX components. I have ver 2.4.0.0 in XE8. Run the demo of Twitter with the same Key and Secret of VCL app and want to start the session this error message appears (happens both Windows and Android):


What can I be doing wrong ?, it is the demo app!

Can anybody help me?

Regards,
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2081
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jun 2015 at 4:27pm
Hi,

We are not aware of any issues with TTMSFMXTwitter component or the TwitterDemo application.
It seems your link to the error message does not work. Can you please let me know what the exact error message is and how the error can be reproduced?
Back to Top
Traversi Angel View Drop Down
Member
Member
Avatar

Joined: 16 Jul 2014
Posts: 40
Post Options Post Options   Quote Traversi Angel Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2015 at 2:20pm
1) Open Twitter Demo
2) Target to iOS Simulator (for example)
3) Complete Key and Secret (taken from the VCL app to work well)
4) Run
5) Press Connect button, and this message appears in safari window:

Whoa there!
The request token for this page is invalid. It may have already been used, or expired because it is too old. 
Please go back to the site or application that sent you here and try agaian; it was probably jist a mistake.

Here the correct message link:
https://www.dropbox.com/s/ja2kgzc6h5yek35/Twitter.png?raw=1

Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2081
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2015 at 3:22pm
This error message usually indicates that the date/time settings on the device you are deploying the application to are not correct.
Can you please make sure the date/time settings are accurate and try again?
Back to Top
Traversi Angel View Drop Down
Member
Member
Avatar

Joined: 16 Jul 2014
Posts: 40
Post Options Post Options   Quote Traversi Angel Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2015 at 9:20pm
Date/time setting is fine.
This error ocurrs in Android, iOS and win32 targets
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2081
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2015 at 9:03am
I have not been able to reproduce this issue on a target device with correct date/time settings.
Can you please provide the key and secret (by email: help@tmssoftware.com) you are using so I can further investigate this?

Edited by Bart Holvoet - 24 Jun 2015 at 9:04am
Back to Top
Traversi Angel View Drop Down
Member
Member
Avatar

Joined: 16 Jul 2014
Posts: 40
Post Options Post Options   Quote Traversi Angel Quote  Post ReplyReply Direct Link To This Post Posted: 24 Jun 2015 at 3:04pm
Sent.

Thanks Bart! 
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down