Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Incompatible Types Error when running in Windows

 Post Reply Post Reply
Author
Macias Jan Webber View Drop Down
New Member
New Member
Avatar

Joined: 10 Dec 2014
Posts: 12
Post Options Post Options   Quote Macias Jan Webber Quote  Post ReplyReply Direct Link To This Post Topic: Incompatible Types Error when running in Windows
    Posted: 20 Feb 2015 at 5:23am
Occurred in the latest update of WebGMaps..

When running map in windows the following error occurred...
Incompatible types: TCefCookieVisitorProc and Procedure in

FMX.TMSWebGMapsWebBrowser.Win.pas
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3574
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 20 Feb 2015 at 8:46am
Hi, 

We have recently updated the ChromiumFMX.zip file that can be downloaded at the following URL:

Kind Regards, 
Pieter
Back to Top
Craig Richard View Drop Down
New Member
New Member
Avatar

Joined: 07 Feb 2013
Posts: 11
Post Options Post Options   Quote Craig Richard Quote  Post ReplyReply Direct Link To This Post Posted: 09 Apr 2015 at 6:47pm
I'm getting this with XE8, will we need a new ChromiumFMX for that?

Thanks
Richard
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3574
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 13 Apr 2015 at 11:30am
Thank you for your feedback.

You are correct, we have re-uploaded the ChromiumFMX.zip file to accomodate for XE8.
If you re-download from the same URL you will be able to compile the TTMSFMXWebBrowser for XE8.

Kind Regards, 
Pieter
Back to Top
Wierzcholowski Karol View Drop Down
New Member
New Member
Avatar

Joined: 24 Jun 2013
Posts: 7
Post Options Post Options   Quote Wierzcholowski Karol Quote  Post ReplyReply Direct Link To This Post Posted: 20 Apr 2015 at 6:51pm
I read that in XE8 we have new WebBrowser component for all platform. We still need chromium browser to use WebGMaps? Can't you use this component?
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3574
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 21 Apr 2015 at 8:31am
Hi, 

Yes we have investigated this here and there are some shortcomings in the TWebBrowser, so currently you still need to use the ChromiumFMX implementation.

Kind Regards, 
Pieter
Back to Top
Engberg Rickard View Drop Down
New Member
New Member
Avatar

Joined: 08 Jan 2015
Posts: 2
Post Options Post Options   Quote Engberg Rickard Quote  Post ReplyReply Direct Link To This Post Posted: 31 Dec 2015 at 4:45pm
Hi,

This still happens when remarking the CHROMIUMOFF define. I am using Seattle, do I need to use Chromium to use GMaps still? There's some unclarity regarding this I think. Trying to use GMaps on Windows crashes the app (different topic, I'll start another thread on that).
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3574
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 31 Dec 2015 at 4:47pm
Hi, 

Starting from XE8, the chromium webbrowser is deprecated. After installation, there are no additional steps needed in order to use WebGMaps.

Kind Regards, 
Pieter


Edited by Pieter Scheldeman - 31 Dec 2015 at 4:48pm
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down