Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

ImageIO

 Post Reply Post Reply
Author
Shelton Brent View Drop Down
New Member
New Member
Avatar

Joined: 29 Mar 2013
Posts: 31
Post Options Post Options   Quote Shelton Brent Quote  Post ReplyReply Direct Link To This Post Topic: ImageIO
    Posted: 05 Sep 2013 at 3:38pm
I installed the mCL trial.  The PDF demo works but the Overview and TableView show an error message 

dyld: Library not loaded: /System/Library/Frameworks/ImageIO.framework/ImageIO Referenced from: /Users/brent/RADPAServer/scratch-dir/brent-vmware/TableView.app/Contents/MacOS/TableView 
Reason: image not found


I tried adding the framework to the SDK Manager but it didn't fix it

Thanks
-Brent
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3243
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2013 at 1:43am
After adding the framework, did you update your local files,
Exexute a clean en rebuild the project?
Back to Top
Shelton Brent View Drop Down
New Member
New Member
Avatar

Joined: 29 Mar 2013
Posts: 31
Post Options Post Options   Quote Shelton Brent Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2013 at 10:25am
Yes and I see that my binary ImageIO is actually here:

/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A

I tried adding that path but it still gives me the error
Back to Top
Shelton Brent View Drop Down
New Member
New Member
Avatar

Joined: 29 Mar 2013
Posts: 31
Post Options Post Options   Quote Shelton Brent Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2013 at 10:35am
I ended up copying my ImageIO.framework folder up to the /System/Library/Frameworks folder

That fixed it.  I'm not sure why typing the complete path to it in the SDK manager didn't work though

On the Overview demo, clicking on the up/down button in edit style datepicker or a date in the calendar style datepicker crashes the app with "10/03/13 is not a valid integer value"
Back to Top
Pieter Scheldeman View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 3243
Post Options Post Options   Quote Pieter Scheldeman Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2013 at 10:41am
Hi, 

We are unable to reproduce this here, but perhaps you are using a different format on your mac?
Can you as test purposes change it to match dd/mm/yy?

Kind Regards, 
Pieter
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down