Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Pushover Issue.

 Post Reply Post Reply
Author
Steve Gill View Drop Down
New Member
New Member
Avatar

Joined: 30 Apr 2015
Posts: 32
Post Options Post Options   Quote Steve Gill Quote  Post ReplyReply Direct Link To This Post Topic: Pushover Issue.
    Posted: 11 Mar 2020 at 7:07am
Are you aware of any changes to the Pushover API that would affect the TAdvPushover component?

When I send messages to a specific device on Pushover, it now sends the message to all devices.  In the past it would only do this if a device wasn't specified.

= Steve


Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2313
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 11 Mar 2020 at 8:48am
Hi,

We are not aware of any changes in the Pushover API and no changes were made to TAdvPushover.
Can you please make sure the device names you are using are valid and assigned correctly to the ADevice parameter?

If the problem persists can you please enable logging to check if the request contains the correct device names?
Logging can be enabled by setting Logging to True and LogLevel to llDetail. The LOG file is generated automatically in the machine's Documents folder.
Back to Top
Steve Gill View Drop Down
New Member
New Member
Avatar

Joined: 30 Apr 2015
Posts: 32
Post Options Post Options   Quote Steve Gill Quote  Post ReplyReply Direct Link To This Post Posted: 17 Mar 2020 at 12:01am
Hi Bart,

Thanks for the advice.  I finally managed to work out what was causing the problems. 

The device names were held in a TStringList, and passed as text, eg. DeviceList.Text.  Doing it like that passes a carriage return and line feed, which I think was confusing Pushover.

So I changed the code to pass the device names as a string, separated by commas, but with no carriage return and line feed.  Now it works fine.

= Steve
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2313
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 17 Mar 2020 at 7:46am
Thank you for confirming the issue was resolved!
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down