Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Logging question?

 Post Reply Post Reply
Author
Czech Tomasz View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 Mar 2017
Posts: 183
Post Options Post Options   Quote Czech Tomasz Quote  Post ReplyReply Direct Link To This Post Topic: Logging question?
    Posted: 26 Jul 2019 at 1:03pm
Hi,

How can I use Logging in many forms?

1) For every form I have to add TMSLogging to uses list.
2) In each forms I have to use the same TMSLogger variable.

This two points are ok?

Regards,
Back to Top
Czech Tomasz View Drop Down
Senior Member
Senior Member
Avatar

Joined: 31 Mar 2017
Posts: 183
Post Options Post Options   Quote Czech Tomasz Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jul 2019 at 2:02pm


I find bug in logging.

If you use sign "<" in logged message e.g.
TMSLogger.Info('Server Start <---');

the output is:
2019-07-26 13:40:00.160, [Info][Value: Server Start 2019-07-26 13:40:00.160, [Info][Value: Server Start <---]

should be:
2019-07-26 13:40:00.160, [Info][Value: Server Start <---]

Regards,
Back to Top
Wagner R. Landgraf View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2877
Post Options Post Options   Quote Wagner R. Landgraf Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2019 at 5:47pm
Yes, two points are ok. 
 Regarding the bug, please contact us directly to get a patch that fixes the problem.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down