Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

Problem rendering TIWDBAdvWebGrid

 Post Reply Post Reply
Author
Lasquibar de la Torre Venancio View Drop Down
New Member
New Member
Avatar

Joined: 28 Oct 2018
Posts: 20
Post Options Post Options   Quote Lasquibar de la Torre Venancio Quote  Post ReplyReply Direct Link To This Post Topic: Problem rendering TIWDBAdvWebGrid
    Posted: 12 Mar 2019 at 8:55pm
Hi
I have Delphi 10.2 Tokyo, and until past week I've used IW 14.2.8 to create an app. I've bought and installed IW 15.0.28 and reinstalled TMS Intraweb controls. Then, my application started to do strange things.  I'm going to describe one.
My application has a welcome form and, when the user chooses an option in a menu, moves to Form 1. This form is fully divided into 6 regions. Region 3 have some data I want to hide or to show, region 4 has a button hide/show, and region 5 has a grid. Region 6 is a footer band. When the user press button in region 4, region 3 hides (visible := False), and region 4 and 5 moves up. Region 5 fills all the remaining space, and table moves up and leave some blank space below. When user press again the button, Region3 is shown and Region 5 size is recalculated to fill the remaining space. Table moves down and fills the region. That's the expected behaviour.
There are 2 cases that reproduces the same problem:
1) switching form
When the user clicks in a row in the grid, application opens a new form (so-called Form2, Detail) in same explorer page. This form has read-only information, and the user can only press a button to close this form. Then, Form1 is shown with the same data as before opening Form2. The question is:
  • If Region3 is visible when user opens Form2, when Form2 closes Form1 is shown correctly
  • If Region3 is hidden when user opens Form2, when Form2 closes the layout is:
          - Regions 1, 2 and 6 in its place (OK)
          - Region 4 just after Region 2 (OK)
          - An empty blank band with size aprox. equal to Region 3 height (bad), between Region4 and Region5
          - Table in Region 5 just after the band, as if Region 3 was visible (bad).
2) Controller paging
If I press a controller button (i.e., "next"), table is repainted in the lower part of the region, showing a blank band between Region 4 and the table

I found a way of solve, but not programmatically. If I press button in region 4 (show Region 3) and press it again (hide Region 3) the page layout is corrected, every region is in its place with its corresponding size, and table is painted at the top of region 5..
I've tried to execute the code associated to the "hide/show" button when I return from Form2, but doesn't work.

Obviously, I've observed this behaviour since I've installed new versions of both softwares (Intraweb and TMS controls); with the previous versions, the form worked fine.
Am I doing something wrong or, on the other hand, is a bug of Intraweb? Could you please help me with this problem?

 Best regards,

                     Venancio Lasquibar
Back to Top
Lasquibar de la Torre Venancio View Drop Down
New Member
New Member
Avatar

Joined: 28 Oct 2018
Posts: 20
Post Options Post Options   Quote Lasquibar de la Torre Venancio Quote  Post ReplyReply Direct Link To This Post Posted: 12 Mar 2019 at 9:01pm
Hi,

Problem solved, changing the property "AsyncPaging" to True

Best regards,
Back to Top
Lasquibar de la Torre Venancio View Drop Down
New Member
New Member
Avatar

Joined: 28 Oct 2018
Posts: 20
Post Options Post Options   Quote Lasquibar de la Torre Venancio Quote  Post ReplyReply Direct Link To This Post Posted: 13 Mar 2019 at 8:30am
.. and setting to true all "Anchors", including specially "bottom"
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down