Web forum is in read-only mode. Login as active registered customer for write access
  Forum Search   New Posts New Posts

No GDrive Connectivity in VCL Cloud Pack

 Post Reply Post Reply
Author
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Topic: No GDrive Connectivity in VCL Cloud Pack
    Posted: 24 Sep 2018 at 3:18pm
Hello,

I use the current version of TMS VCL Cloud Pack. Since a few days it isn't possible to connect with Google drive, neither with InternalBrowser nor with ExternalBrowser. After authentication only a white site appears.

I've tested it with your CloudStorageDemo and there is the same problem.

In the CloudStorageDemo from TMX FMX Cloud Pack all works fine.

Could you check it please?
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2215
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2018 at 3:49pm
We have noticed issues with authentication in TAdvGDrive from time to time over the last couple of weeks.
It seems these issue are related to he Google Drive API and they go away automatically after some time.
Back to Top
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Posted: 24 Sep 2018 at 5:07pm
The problem lasts almost a few days.
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2215
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 8:52am
I haven't been able to reproduce the issue anymore yesterday or today.
If the problem persists, please provide a LOG file so I can further investigate this.
Logging can be enabled by setting Logging to True and LogLevel to llDetail.
The LOG file is generated automatically in the machine's Documents folder.
Back to Top
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 3:09pm
Hello,

the problem still exists today. 

I start the VCL CloudStorage with GDrive and I have to authentify me.
My possible accounts will be listed in the browser and I select one. The result is a blank page without any text.

Here is the detailed log file: TAdvGDrive.LOG

20180925T145647:HTTPS GET: https://www.googleapis.com/drive/v2/about/?access_token=
20180925T145648:HTTPS GET RESULT:{
 "error": {
  "errors": [
   {
    "domain": "global",
    "reason": "required",
    "message": "Login Required",
    "locationType": "header",
    "location": "Authorization"
   }
  ],
  "code": 401,
  "message": "Login Required"
 }
}

20180925T145648:HTTPS GET: https://www.googleapis.com/drive/v2/about/?access_token=
20180925T145648:HTTPS GET RESULT:{
 "error": {
  "errors": [
   {
    "domain": "global",
    "reason": "required",
    "message": "Login Required",
    "locationType": "header",
    "location": "Authorization"
   }
  ],
  "code": 401,
  "message": "Login Required"
 }
}

20180925T145701:HTTPS GET: https://www.googleapis.com/drive/v2/about/?access_token=
20180925T145702:HTTPS GET RESULT:{
 "error": {
  "errors": [
   {
    "domain": "global",
    "reason": "required",
    "message": "Login Required",
    "locationType": "header",
    "location": "Authorization"
   }
  ],
  "code": 401,
  "message": "Login Required"
 }
}

20180925T145702:HTTPS GET: https://www.googleapis.com/drive/v2/about/?access_token=
20180925T145702:HTTPS GET RESULT:{
 "error": {
  "errors": [
   {
    "domain": "global",
    "reason": "required",
    "message": "Login Required",
    "locationType": "header",
    "location": "Authorization"
   }
  ],
  "code": 401,
  "message": "Login Required"
 }
}


If do I compile the FMX version of the CloudStorage then the program will list the files without authentification. Maybe the token from VCL is valid.

Do I use the VCL version of CloudStorage again, then  i have to authentify me again with the result of the blank page.

Both versions use the same Url http://127.0.0.1:8889/ and Port 8889

Back to Top
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 3:11pm
And do I clear the acces token then the FMX versionwill also open the browser, I select my account and then the correct result appears: 

"Application succesfully authorized. You can close this browser window"
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2215
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 3:55pm
I'm not sure what is going wrong as we still haven't been able to reproduce this issue.

Can you try running the application on a different computer and/or on a different network?
Back to Top
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 4:01pm
Some of my customers have this problem too on other machines and other networks. 
They pointed me to the problem. But I can check it on another machine in my house.
Back to Top
Schröder Heiko View Drop Down
Member
Member
Avatar

Joined: 30 Nov 2010
Posts: 52
Post Options Post Options   Quote Schröder Heiko Quote  Post ReplyReply Direct Link To This Post Posted: 25 Sep 2018 at 4:08pm
As expected the same problem.

The browser opens, ask for the account and the password.
The the site appears where I have to accept the access of the program to my GDrive.
And then: blank page and no connect in your VCL example program.
The log file shows the same like above.
Back to Top
Bart Holvoet View Drop Down
TMS Support
TMS Support
Avatar

Joined: 18 May 2010
Posts: 2215
Post Options Post Options   Quote Bart Holvoet Quote  Post ReplyReply Direct Link To This Post Posted: 26 Sep 2018 at 3:53pm
As we are unable to reproduce the issue would it be possible to provide the API Key and Secret values you are using to check if that makes a difference?
You can provide the values by sending an email to: mailto:help@tmssoftware.com
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down